Very Significant Vulnerability in Firefox

ShareShare on FacebookTweet about this on TwitterPin on PinterestShare on Google+Share on Reddit

Now all the people talking about how secure Firefox is have to bite their tongue. And, to fix it, you have to download a new browser (after they decide to release a patch), not just a <1MB (usually) patch (like IE). Works on mac and *nix too. 🙁

it was only a matter of time

This entry was posted in Old Blog and tagged . Bookmark the permalink.

0 Responses to Very Significant Vulnerability in Firefox

  1. Jon says:

    In the words of Bill and Ted, “Bummer dude.”

  2. Ben says:

    Just did the update to 1.0.4 due to this issue…. and while it was a full update and not a patch…. it was still much quicker then even a single patch for IE. Of course, over a modem, things would probably be different.

Leave a Reply

Your email address will not be published. Required fields are marked *